nix/hosts/phone/default.nix
2024-09-28 12:06:19 +02:00

77 lines
1.3 KiB
Nix

{
config,
lib,
pkgs,
...
}: {
# Simply install just the packages
environment.packages = with pkgs; [
# User-facing stuff that you really really want to have
vim # or some other editor, e.g. nano or neovim
zsh
fish
font-awesome
fastfetch
ipfetch
ffmpeg
yt-dlp
lazygit
# toybox
unixtools.ping
cowsay
# Some common stuff that people expect to have
procps
# killall
openssh_hpn
git
diffutils
findutils
utillinux
tzdata
# hostname
man
gnugrep
gnupg
gnused
gnutar
bzip2
gzip
xz
zip
unzip
];
# Backup etc files instead of failing to activate generation if a file already exists in /etc
environment.etcBackupExtension = ".bak";
# Read the changelog before changing this value
system.stateVersion = "24.05";
# Set up nix for flakes
nix.extraOptions = ''
experimental-features = nix-command flakes
'';
# Set your time zone
time.timeZone = "Europe/Berlin";
home-manager.config = {
home.stateVersion = "24.05";
imports = [
./home
];
# config = ./home.nix;
};
user.shell = "${pkgs.zsh}/bin/zsh";
terminal = {
colors = {
background = "#282828";
foreground = "#fbf1c7";
};
};
}